Jump to content
Sign in to follow this  
yumehana

High GPU usage while playing Sabbat of the Witch

Recommended Posts

Hello everyone,

I'm playing Sabbat of the Witch on my PC and while the game is running, GPU usage is about 70-75%.

This shouldn't be normal as I can play the game on the Surface 3 (Atom CPU) with some choppiness so it should not be too GPU-intensive like this.

What can I do to fix this? 

Thanks in advance.
 

My PC specs is:

AMD Ryzen 5 1600X

16GB RAM

nVidia GTX 1070 with latest driver (11/12)

Windows 10 64 bit 1803

 

P/s: this is the legitimate Steam copy so there is no chance that it's because of virus or miner software. 

 

Screenshot1.png

Screenshot2.png

Edited by yumehana

Share this post


Link to post
Share on other sites

Do you play with unlocked framerates?
That said a high GPU usage is generally desirable provided that your GPU temperature isn't too high and you are not having any graphical bugs, glitches etc.
I have 60% GPU while playing Sanoba myself with unlocked framerates and I have a GTX1080 TI. When I cap the framerate to 60 or 30 I drop down to 10%.
But generally, a high GPU usage is a good thing because it means that your CPU isn't bottlenecking your GPU.

When I play AAA titles my GPU is always at around 90-100%.

But if you want to restrict your GPU usage I would suggest limiting your framerate.
 

Share this post


Link to post
Share on other sites
On 11/17/2018 at 3:42 AM, Neb Neb said:

Do you play with unlocked framerates?
That said a high GPU usage is generally desirable provided that your GPU temperature isn't too high and you are not having any graphical bugs, glitches etc.
I have 60% GPU while playing Sanoba myself with unlocked framerates and I have a GTX1080 TI. When I cap the framerate to 60 or 30 I drop down to 10%.
But generally, a high GPU usage is a good thing because it means that your CPU isn't bottlenecking your GPU.

When I play AAA titles my GPU is always at around 90-100%.

But if you want to restrict your GPU usage I would suggest limiting your framerate.
 

 

Thank you very much! After changing max framerate setting to 60fps, my GPU usage dropped to 10-15% ingame. :'D 

I'm aware that other games using Kirikiri engine has max frame rate setting but I couldn't find it in Sanoba Witch. It's a bit unintuitive that a graphic setting toggle is hidden in the Help menu imo.

 

 

 

Edited by yumehana
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×